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Introduction

Purpose

This document is intended for red or amber AlphaEclipse 2500, 2600, 
and 3500 signs. It explains how to use Jasc Software’s Paint Shop Pro and 
Animation Shop to

• use existing graphics, such as Internet images, digital 
photographs, and GIF animations.

• create simple graphics from scratch.

Revision history

Related documentation

NOTE: If possible, either print this document in color or view it as a 
PDF file on a computer screen to see the color images used in 
this manual.

NOTE: Paint Shop Pro version 5.03 and Animation Shop version 1.03 
software were used in this document.

Revision Date Notes

9700-0130 July 24, 2003 First release

9700-0130A May 24, 2004 Second release

Part # Manual title Description

9708-8081F AlphaNET Version 2.0.3 
User Manual

Explains how to create and send 
messages to signs using AlphaNET 
software.

Creating graphics for AlphaEclipse signs

http://www.adaptivedisplays.com
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2 Signology 101

Signology 101

Before starting to work with images, it is necessary to understand how size, color, and aspect ratio affect 
graphics displayed on a sign. A basic knowledge of these three properties will make it easier to select, modify, and 
create a graphic, and, hopefully, improve its appearance on a sign.

Lesson 1: Only small graphics can be displayed on a sign

Both sign and graphic sizes are measured in pixels — the smallest unit or building block of a sign or image. 
Examples below compare typical graphic sizes with AlphaEclipse sign sizes:

• This GIF graphic of the United States is 110 pixels long by 76 pixels tall (or simply 110 x 76):

• This picture of dogs, taken with a 3-megapixel 
digital camera, has 24-million colors and is 2048 
x 1536 pixels. This is big! In order to fit on this page, 
the image had to be reduced by 75% because its actual 
size is over 28 x 21 inches.

• By comparison, the size of AlphaEclipse 3500 signs range from 32 x 8 to 144 x 32 pixels. Using the two 
graphics above as examples, here is what you would see on the largest (144 x32) sign:

While the length of the United States image (110 pixels) fits on this sign, only about half 
of its height (76 pixels) appears.

The only part of the dog photograph that would be visible on the sign is the eye of one of 
the dogs (shown by the white box on the picture above).
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Lesson 2: Very few details in a graphic can appear on a sign

Because a sign can only display very small graphics, there are not a lot of pixels to work with. In addition, a 
sign only has two colors — LED on (either red or amber), LED off. All the colors in an image must be reduced to 
just two colors. This loss of color ensures that many details will be lost.

These two factors, small size and limited colors, greatly reduce the amount of detail that can be included in an 
image. Despite this, there are still many graphics available, especially on the Internet, that can be used with little or 
no modification to liven up a sign’s message. See “Resources” on page 14 for a list of sources for these images.

This is how the United States graphic from the previous page would look on a 96 x 16 sign:

Here is a version of the United States graphic, modified using PaintShop Pro, with less detail:

Lesson 3: Use PaintShop Pro and Animation Shop to edit graphics

PaintShop Pro is designed to edit regular (non-animated) GIF graphics. However, if an animated GIF is edited 
with PaintShop Pro software, only the first picture or frame of the animation will be saved. Unless the original 
animated GIF was saved, all the movement would be lost. Animation Shop should be used for animated GIFs

Only a few of the stars remain.

The white bars now make it difficult to 
recognize the shape of the United States.

The color blue has disappeared 
and merged with the red bars.
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Examples

Example 1 — Using a still image on a sign

In this example, this 256-color, 64 x 64 pixel clock GIF graphic (shown above as twice its actual size) will be 
edited in Paint Shop Pro for a 96 x 32 sign. This graphic was downloaded from IconBAZAAR (see “Resources” on 
page 14).

In order to use the clock GIF, both its size and colors must be scaled down. This reduces the amount of detail in 
the graphic and could leave the final image unrecognizable and unfit for use. There is really no way of knowing 
except by trial and error and by developing a keen eye for spotting usable images. Previewing an image with 
AlphaNET software will help in this process.

Preview the graphic using AlphaNET software
Before beginning to edit, check for potential problems by previewing the graphic with AlphaNET software.

1. Click Start > Programs > AlphaNET > Message Editor.

2. In the message window, click Modes > Hold > Fill (for Line Position). The Hold mode makes the graphic 
look better because it prevents the sign from using Automode.

3. Click Options > Gif and select the GIF file you want to preview, in this case the alarm clock.

4. Click File > Simulate to preview the clock graphic:

NOTE: Set the simulator to the correct sign size. To do this, place your cursor over the simulator and right 
click. From the pop-up, click Change Display and select the sign type and size (96 x 32 in this case).

Hold icon with Fill Line Position

GIF icon

32
pixels

96 pixels

Even though this clock 
graphic must be reduced in 
size, it looks like it can be 
used on this sign.

However, some detail will be 
lost. Numbers on the clock 
face will probably not be 
recognizable when this 
graphic is scaled down.

If no image appears on the simulator, try selecting 
AlphaEclipse 3600 instead and type in the number 
of Columns and Rows. (The AlphaEclipse 3600 can 
display almost any color.)
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Shrink the graphic

5. In Paint Shop Pro, click File > Open and select the still image. Then click Open.

6. Click View > Image Information for a list of properties about this graphic. Check the dimension and colors:

7. Click OK to close the Current Image Information window.

8. Next, click Image > Resize > Pixel Size, and after Height, type the sign’s height (in this case, 32):

9. Click OK to close the Resize window.

Dimension = 64 x 64 Pixels
To fit on the sign, the height must be reduced to 
32 pixels. The height and width should both be 
reduced proportionally, preserving the graphic’s 
aspect ratio. Otherwise, the image could end up 
looking “squashed”, like the alarm clock on the 
right.

Pixel Depth/Colors = 8/256
The Pixel Depth is the amount of color information each pixel 
holds in the graphic. In this case, the amount of color 
information or depth is 8 bits which equals 256 colors (or 
28). Color rich graphics are 24- or 32-bit deep which results 
in 16.7 (224) million or 4.3 (232) billion colors, respectively.
Remember, sign graphics must be reduced to 2 colors or 1-
bit (21). All those “extra” colors will be reduced to either LED 
“on” or “off”.

Check Maintain aspect ratio of 1 to 1.
This means that, for example, if a graphic’s height is reduced by 
25%, its width will also be reduced by the same percentage. This 
avoids “squashed” graphics.

Width x Height
After a height is typed, the width will change automatically.
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Reduce the number of colors in the graphic

10. Since the resized graphic is very small, make it more viewable on screen. Click View > Zoom In > 8:1:

Outline the graphic in black
Before reducing the colors in this GIF graphic from 256 to just two, use the paint brush tool in Paint 

Shop Pro to outline the alarm clock in black. If this is not done and the image is reduced, the graphic may “fall 
apart” and become unrecognizable as shown below:

11. To start outlining the image, click on the paint brush tool .

12. If the Controls palette is not displayed, click and then Brush Tip:

Click and drag this corner down until the 
hatched area appears on all sides of the 
graphic. This will make it easier to select.

After the graphic is reduced in 
size, the numbers on the dial have 
become unreadable.

This graphic was not outlined in black 
before it was reduced to two colors. 
Because of this, some of the colors have 
simply disappeared.

Set Size = 1.

Set Shape = Square.
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13. Use the paint brush tool to outline the alarm clock graphic in black:

Decrease the number of colors in the graphic to two

14. After outlining the graphic, click Colors > Decrease Color Depth > 2 Colors (1 Bit):

15. Click OK to close the Decrease Color Depth window:

Black outline

Partially outlined Fully outlined

Palette component = Grey values

Palette weight = Weighted

Reduction method = Nearest color
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Clean up the graphic with the paint brush and eraser tools

NOTE: Make sure that Brush Tip > Size in the Controls palette is set to 1 for both the paint brush and the eraser 
tools. Otherwise, too many pixels may be added or erased in the graphic.

16. Edit the graphic by removing unnecessary parts with the eraser tool, and by adding detail with the paint 
brush tool:

Convert black to red
If the alarm clock graphic was displayed on a sign as it is now, nothing would appear. This is because both 

black and white turn sign LEDs off. However, a red graphic will appear on a sign.

17. Click Colors > Edit Palette to display all the colors used — in this case, two — in this graphic. Then double 
click on the color black:

18. When the Color window appears, click on the color red:

8:1 Zoom In 2:1 Zoom In

As you edit, occasionally view the graphic at a 
reduced zoom, like 2:1.

This smaller size more accurately represents 
how the image will look on the sign.

Double click on the color black.

Clicking on red will replace black with 
red in the alarm clock graphic.
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19. Click OK to close the Color window. Then click OK again to close the Edit Palette window. This changes 
black into red in the alarm clock:

Turn Transparency off
“Transparency” is a special property of a GIF file that is usually used to make the white background of a GIF 

invisible so that a graphic blends into a web page.
However, on a sign, if the alarm clock GIF is displayed with transparency on, this is what would appear:

20. Click Colors > Set Palette Transparency > No transparency > OK.

21. Then click File > Save to save the alarm clock GIF file.

Red outline

Where did the clock go?

Transparency on turns a 
GIF into a solid block.
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Test the graphic on a sign using AlphaNET software

22. Click Start > Programs > AlphaNET > Message Editor.

23. In the message window, click Modes > Hold > Fill (for Line Position). The Hold mode makes the graphic 
look better because it prevents the sign from using Automode.

24. Click Options > Gif and select the GIF file you just saved.

25. Click File > Transmit. At the prompt, select either To All Sites or To Selected Sites depending on how your 
sign is set up. Then click OK. In a few moments the clock GIF will appear on the sign:

Hold icon with Fill Line Position

GIF icon
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Example 2 — Using animated graphics on a sign

Like still images, either select or create an animated GIF that is simple and not full of detail.
Unlike still images, colors should not be reduced in an animated GIF. Though it is possible to change the colors 

in a GIF file, it is very tedious, especially in animations with many frames such as the following example.
In this example, a 256-color, 64x 48 pixel, 44-frame animated GIF arrow is used. This GIF was downloaded 

from IconBAZAAR (see “Resources” on page 14):

Frame number
(1 of 44 in this animated GIF)

Display time in 1/100th seconds
(In this case, Frame 1 will be displayed 
6/100 seconds. Then the animation will 
go to Frame 2, and so on.)
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Preview the animated GIF using AlphaNET software
Before beginning to edit, check for potential problems by previewing the graphic with AlphaNET software.

1. Click Start > Programs > AlphaNET > Message Editor.

2. In the message window, click Modes > Hold > Fill (for Line Position). The Hold mode makes the graphic 
look better because it prevents the sign from using Automode.

3. Click Options > Gif and select the GIF file you want to preview, in this case the moving arrow.

4. Click File > Simulate to preview the moving arrow. Two of the 44 frames in this animated graphic are 
shown:

NOTE: Set the simulator to the correct sign size. To do this, place your cursor over the simulator and right 
click. From the pop-up, click Change Display and select the sign type and size (96 x 32 in this case).

Frame 1

Frame 3

In order to display this 
graphic, the simulator had 
to be set to AlphaEclipse 
3600 (see following note).

32
pixels

96 pixels

If no image appears on the simulator, try 
selecting AlphaEclipse 3600 instead and type in 
the number of Columns and Rows. (The 
AlphaEclipse 3600 can display almost any color.)
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Shrink the animated GIF

5. In Animation Shop, click File > Open and select the animated GIF file. Then click Open:

6. Click Edit > Resize Animation and after Height, type the sign’s height (in this case, 32):

7. Click OK to close the Resize window.

8. Click File > Save to save the resized animation.

Test the animated GIF on a sign using AlphaNET software

9. Do the steps in “Test the graphic on a sign using AlphaNET software” on page 10.

Style Bar
The size and number of frames in the animation.

Zoom
Increases/decreases the 
view of each frame.

Check Maintain aspect ratio of 1 to 1.
This means that, for example, if a graphic’s height is 
reduced by 25%, its width will also be reduced by the same 
percentage. This avoids “squashed” graphics.

Width x Height
After a height is typed, the width will change automatically.
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Resources

Web links

Color table

The table below shows how 16 common colors appear on an AlphaEclipse sign:

URL Site Name Description

http://www.adaptivedisplays.com Adaptive Micro Systems
The Adaptive site contains monochrome and 
color animations for 16-, 24-, and 32-row 
signs.

http://www.tickermedia.com Ticker Media Source for custom content for indoor or 
outdoor advertising displays.

http://www.iconbazaar.com IconBAZAAR Source for small images and animated GIFs.

http://www.icon-editor.net Icon Editor Software
Software designed for creating and editing 16 
x 16, 32 x 32, 48 x 48, or 64 x 64 graphics that 
have a small number of colors.

http://www.icons-online.com Icons Online Companion site for the Icon Editor software.

http://www.davedigitalworks.com DaveDigitalWorks This site has free sign animations for Adaptive 
signs.

Color RGB values Visible on a
RED AlphaEclipse?

Visible on an
AMBER AlphaEclipse?

Black R000 G000 B000 No No

Dark Blue R000 G000 B128 Yes Yes

Blue R000 G000 B255 Yes Yes

Dark Green R000 G128 B000 No No

Teal R000 G128 B128 No No

Green R000 G255 B000 No No

Light Blue R000 G255 B255 No No

Brown R128 G000 B000 Yes Yes

Purple R128 G000 B128 Yes Yes

Olive Drab R128 G128 B000 Yes Yes

Gray R128 B128 B128 Yes Yes

Light Gray R192 G192 B192 Yes Yes

Red R255 G000 B000 Yes Yes

Pink R255 G000 B255 Yes Yes

Yellow R255 G255 B000 Yes Yes

White R255 G255 B255 No No

http://www.adaptivedisplays.com
http://www.tickermedia.com
http://www.iconbazaar.com
http://www.icon-editor.net
http://www.icons-online.com
http://www.davedigitalworks.com
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