
How to use the IR Message Loader
to Display Messages on AlphaEclipse Signs

http://www.adaptivedisplays.com

© Copyright 2003 Adaptive Micro Systems, LLC. All rights reserved.
Adaptive Micro Systems • 7840 North 86th Street • Milwaukee, WI 53224 USA • 414-357-2020 • 414-357-2029 (fax) • http://www.adaptivedisplays.com

Trademarked names appear throughout this document. Rather than list the names and entities that own the trademarks or insert a trademark symbol with each mention of the 
trademarked name, the publisher states that it is using names for editorial purposes and to the benefit of the trademark owner with no intention of improperly using the trademark.

The following are trademarks of Adaptive Micro Systems: ActiveX, Adaptive, Alpha, AlphaLert, AlphaNET, AlphaNet plus, AlphaEclipse, AlphaPremiere, AlphaTicker, AlphaVision, 
AlphaVision InfoTracker, Automode, BetaBrite, BetaBrite Director, BetaBrite Messaging Software, Big Dot, Director, EZ KEY II, EZ95, PagerNET, PPD, PrintPak, Serial Clock, Smart Alec, 

Solar, TimeNet.
The distinctive trade dress of this product is a trademark claimed by Adaptive Micro Systems, LLC.

Due to continuing product innovation, specifications in this manual are subject to change without notice.

November 4, 2003 9707-1004

Create a site using AlphaNET Site Manager (page 10).

Store the messages in the IR Message Loader (page 14).

Create messages for the sign using AlphaNET Message Editor (page 12).

Wire a Modular Network Adapter to an AlphaEclipse sign (page 5).

Send the messages from the IR Message Loader to the sign (page 15)

These instructions apply to the following signs:

• AlphaEclipse 2500 series
• AlphaEclipse 2600 series
• AlphaEclipse 3500 series

These instructions are not for Alpha or Betabrite signs. For 
these signs, see “How to use the IR Message Loader to 
Display Messages on Alpha Signs” (pn 9707-1003F).

Set the AlphaEclipse sign to the correct baud rate (page 8).

Connect the IR Message Loader to a computer (page 9).
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Introduction

Overview

These instructions explain how to use an IR Message Loader to display messages on the following signs:

• AlphaEclipse 2500 series

• AlphaEclipse 2600 series

• AlphaEclipse 3500 series

IR Message Loader description

Item Name Description

A MEMORY LOCATION switch Selects into which memory location (1, 2, or 3) messages will be stored. Each 
memory location can store up to 10,000 bytes.

B DATA VALID light Solid — messages successfully sent or received
Blinking — messages being transferred.

C Infrared transmitter not used

D DATA light Blinks when data is sent to or received from the IR Message Loader.

E BAT. LOW light When lit, indicates that the unit’s 9V battery should be replaced.

F TRANSMIT button Sends or receives messages.

G Serial port Connects to a computer to receive messages, or to a sign to send or receive 
messages.

A

B C D

E

F

G

These instructions are not for Alpha 
or Betabrite signs. For these signs, 
see “How to use the IR Message 
Loader to Display Messages on Alpha 
Signs” (pn 9707-1003F).



IR Message Loader Instructions for AlphaEclipse Signs (pn 9707-1004) November 4, 2003

4 Revision history

Revision history

Related documentation

Part number Date Notes

9707-1004 November 4, 2003 First release.

Document name Part # Description

AlphaNET User Manual 9708-8081 Explains how to use this software to create sign messages.

How to use the IR Message Loader 
to Display Messages on Alpha Signs 9707-1003F Explains how to use the IR Message Loader with Alpha and Betabrite 

signs.

AlphaEclipse 3500 Series A Sign 
Service Manual 9711-6009B Explains how to maintain, troubleshoot, and repair AlphaEclipse 3500 

Series A signs.

AlphaEclipse 3500 Series B Sign 
Service Manual 9711-6019 Explains how to maintain, troubleshoot, and repair AlphaEclipse 3500 

Series B signs.
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Wire a Modular Network Adapter to an AlphaEclipse sign

Overview

In order to use an IR Message Loader with an AlphaEclipse sign, the sign must be connected to a Modular 
Network Adapter, usually located near the base of the sign:

Open the sign

1. Remove power from the AlphaEclipse sign.

2. Open the sign door.

3. Fasten the safety bar on one or both sides of the sign door.

NOTE: On some signs, the safety bar automatically fastens when the sign door is raised.

4. Remove the screws from each of the sign’s vertical rails.

5. Placing your hands underneath the metal rails, lift the LED boards up. Lower each red prop rod from 
underneath the LED boards. Then place each prop rod in the sign case hole nearest to the prop rod.

6. Put the internal power switch in the OFF (0) position.

AlphaEclipse

RS485 outdoor cable (pn 7122-0284) connects 
the sign to the Modular Network Adapter.

Modular Network Adapter (pn 4331-0602) 
in a watertight housing.

IR Message Loader
(pn 1071-1113)

connects to the Modular 
Network Adapter.

{The distance between the sign 
and the Modular Network 
Adapter can be up to 4000 feet.

Loader-to-sign cable

(pn 1088-8628)

Contact with high voltage
may cause death or serious
injury.
Always disconnect power to 
unit prior to servicing.

Hazardous voltage.

WARNING

SM1000A
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Connect RS485 outdoor cable to the sign

7. Locate the sign’s controller board. It is usually located in the front right side of the sign as in the 
AlphaEclipse 2600 sign shown below:

8. Run RS485 outdoor cable from the base of the sign into the back of the sign through the conduit opening 
nearest the sign’s controller board. The RS485 wire should not be run through the same conduit with the wires 
supplying power to the sign.

NOTE: If you have two signs connected as a Master/Slave pair, run the RS485 wire to the Master sign.

Controller board

White terminal block

Conduit opening
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9. Connect the RS485 wires to the sign in one of two ways:

• If there is a white terminal block in the sign, connect the RS485 wire to this block:

• If there is no white terminal block in the sign, then connect the RS485 wire to the controller board:

10. Put the internal power switch in the ON (1) position.

11. Before you close the sign, see if the sign’s baud rate is correct (see “Set the AlphaEclipse sign to the correct 
baud rate” on page 8).

Connect the RS485 outdoor cable to the Modular Network Adapter

12. Wire the Modular Network Adapter as shown:

13. Apply power to the sign.

GND
RS232 RXD
RS232 TXD
SHIELD
RS485B (-)
RS485A (+)

RS485 outdoor cable
Green

not connected
Yellow
Black

Red
White

Green
Yellow
Black

Red
White

Black
Red
SHIELD

Controller board

White terminal block

SERIAL
PORT

1
2
3
4
5
6
7

RS485 outdoor cable

Red
Black

Controller board

SERIAL
PORT

1
2
3
4
5
6
7

Do not connect the SHIELD 
wire to the controller board.

Black wire (RS485+)
connects to black wire terminal

Red wire (RS485-)
connects to yellow wire terminal

SHIELD wire
connects to red wire terminal
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Set the AlphaEclipse sign to the correct baud rate

14. To see if the sign is set correctly, turn power to the sign off and then on again. Messages similar to the 
following will appear on the sign:

15. If the sign is not set to either of the above (“AUTO BAUD” or “2400, 7e2”), then turn off power to the sign, 
open the sign door, and set the controller board DIP switches to AUTO BAUD as shown below:

11705001D
ECLIPSE

ECLIPSE
M-096x016

SER ADDR
01 HEX

AUTO BAUD
7E2 / 8N1

PERF REV
11704001A0200

and so on . . .

11705001D
ECLIPSE

ECLIPSE
M-096x016

SER ADDR
01 HEX

SER. DATA
2400, 7e2

PERF REV
11704001A0200

and so on . . .

If you see either one of 
these settings, then the 
sign is set correctly.

Contact with high voltage
may cause death or serious
injury.
Always disconnect power to 
unit prior to servicing.

Hazardous voltage.

WARNING

SM1000A

ON
12345678910

ON
12345678910

Bank 2 Bank 1

Controller board

Only set these DIP switches (off = down).
Leave the other switches alone!
• Bank 1 — DIP switches #3, 4, and 5 off.
• Bank 2 — DIP switch #8 off.
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Connect the IR Message Loader to a computer

IR Message Loader
(pn 1071-1113)

Loader-to-PC cable
(pn 1036-9010)

Computer COM port

Turn off your computer before 
connecting the IR Message Loader.
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10 Create a site using AlphaNET Site Manager

Create a site using AlphaNET Site Manager

1. Open the AlphaNET Site Manager software:

2. Click Edit > Connection Device. Then click Local Wired Com 1 > Edit:

3. Set the COM Port, Data Format, and Baud Rate as shown below. Then click OK:

• If you don’t see Local Wired Com 1, then click 
Add and select the appropriate Local Wired 
device.

• If you connected the IR Message Loader to 
another COM port, then click Add and select 
the appropriate Local Wired device.

COM Port
Set this to the computer COM 
port that is connected to the IR 
Message Loader.

Data Format
Set to 7E2.

Baud Rate
Set to 9600. (This is the speed 
that your computer sends 
messages to the IR Message 
Loader.)
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4. Click Make Default > Yes > OK:

5. From the AlphaNET Site Manager screen, click File > New Site. Enter the information as shown below. 
Then click OK.
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Create messages for the sign using AlphaNET Message Editor

1. From the AlphaNET Site Manager screen, click the Message Editor icon . Then enter a message:

2. Click File > Save As. Name this message “message1”. Then click Save:

3. Click File > Close to close the message1 window.

4. From the AlphaNET Site Manager screen, click Message Loader Site:

A sign’s time and date can not be 
updated using the IR Message Loader.

To change the time and date on a sign, 
see “Troubleshooting” on page 16.



November 4, 2003 IR Message Loader Instructions for AlphaEclipse Signs (pn 9707-1004)

Create messages for the sign using AlphaNET Message Editor 13

5. Click the add message icon . Then select message1:

6. Click Open. This adds message1 to the Message Loader Site:

7. Select Message Loader Site. Click the transmit icon :

One or more messages can be “attached” 
to a site.

All the messages that are attached to a 
site will be sent to the IR Message 
Loader.

Because IR Message Loader memory is 
limited, be careful of attaching too many 
messages to the Message Loader Site.

Do NOT click OK yet!



IR Message Loader Instructions for AlphaEclipse Signs (pn 9707-1004) November 4, 2003

14 Store the messages in the IR Message Loader

Store the messages in the IR Message Loader

1. On the IR Message Loader, move the MEMORY LOCATION switch to 1, 2, or 3 to select where to store 
your messages:

2. Press and release TRANSMIT on the IR Message Loader. When DATA blinks once, go to the next step. You 
only have 10 seconds.

3. From the AlphaNET Site Manager screen, click Selected Sites > OK:

4. DATA will blink as messages are sent from the computer to the IR Message Loader.

5. When all messages have been sent to the IR Message Loader, both DATA VALID and DATA will go off.

In this picture, MEMORY LOCATION has been set to 3.

Click Selected Sites. Then click OK.
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Send the messages from the IR Message Loader to the sign

1. Using a Loader-to-sign cable, connect the IR Message Loader to the Modular Network Adapter that is 
connected to the AlphaEclipse sign:

2. On the IR Message Loader, move the MEMORY LOCATION switch to 1, 2, or 3 to select where your 
message are stored:

3. On the IR Message Loader, press and hold TRANSMIT. Watch the DATA light. When it goes off, stop 
pressing TRANSMIT.

4. If RECEIVED OK appears on the sign, then the transfer was successful and your message should appear 
on the sign. However, if an error message appears, then repeat from step 4.

Loader-to-sign cable
(pn 1088-8628)

Modular Network Adapter
(pn 4331-0602)

In this picture, MEMORY LOCATION has been set to 3.
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Troubleshooting

Problem Solution

No messages appear on sign

• Make sure the sign has power.

• Turn the sign off then on again. Watch for the baud rate message:

• Move the MEMORY LOCATION switch to a different number (1, 2, or 3). Then try 
sending messages to the sign again.

• Try storing messages in the IR Message Loader again. Then send these messages 
to the sign. Use the same MEMORY LOCATION number for storing and sending 
messages.

• Your message(s) may be too large. Create a short text message using AlphaNET 
software. Then try sending this message to the IR Message Loader and then to the 
sign.

• Try using a different Loader-to-PC cable.

• Replace the battery in IR Message Loader. 

Time and date not correct on sign

• To change the time and date on an AlphaEclipse sign, connect a computer running 
AlphaNET software to the sign. Connect the computer RS232 port to the sign’s 
controller board. See the “Networking signs” section in either the AlphaEclipse 
Series A or Series B service manual for wiring details.

NOTE: If you have an AlphaEclipse 2500 or 2600 sign, use the AlphaEclipse Series 
B service manual.

• Send a message to the sign with the correct time and date:

11705001D
ECLIPSE

ECLIPSE
M-096x016

SER ADDR
01 HEX

AUTO BAUD
7E2 / 8N1

PERF REV
11704001A0200

and so on . . .

11705001D
ECLIPSE

ECLIPSE
M-096x016

SER ADDR
01 HEX

SER. DATA
2400, 7e2

PERF REV
11704001A0200

and so on . . .

If you see either one of 
these settings, then the 
sign is set correctly.

AlphaNET uses your 
computer’s time and 
date, so make sure 
these are correct.
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Appendix

Replacing the battery in an IR Message Loader

The IR Message Loader is powered by a 9-volt alkaline battery which should be replaced 
when

•BAT. LOW light remains on

•after repeated attempts, the IR Message Loader is unable to either receive or transmit 
messages

To replace the battery, slip off the battery cover on the back on the unit. Then replace the 
battery with a new one (as shown on the right).

Updating the firmware in an IR Message Loader

Firmware is the operating system for the IR Message Loader and is contained in a small chip inside the unit. 
From time to time, it may be necessary to update the firmware by replacing this chip.

To update the firmware, follow these steps:

1. Disconnect the battery from the IR Message Loader.

2. Remove the four screws from the back of the unit. Then pull the back off of the unit to expose the firmware 
chip:

3. Place the tip of a small screwdriver under the firmware chip. Then gently pry the chip out of its socket.

4. Place the new firmware chip in the socket and press it into place.

5. Reattach the unit’s cover.

6. Reconnect the unit’s battery.

( c ) AMS   1071 - 6003H
   2003            CS=38E0

( c ) AMS   1071 - 6003H
   2003            CS=38E0

Firmware version (“H” in this case)
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