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Networking ALPHA signs with ALPHA Ethernet Adapters

This document explains how to use ALPHA Ethernet Adapter 

serial servers to network ALPHA signs over an Ethernet Local 

Area Network (LAN). To send messages, you can use 

AlphaNET plus for Windows or Smart Alec software.

NOTE: Installation and setup for this product requires a 
network-literate Information Systems professional.

NOTE: AlphaNET plus for Windows is compatible with Windows 3.1, 
Windows 95, and Windows NT. Smart Alec 1.8 is compatible 
with Windows 95 and Windows NT. Smart Alec 2.1 is 
compatible with Windows 95, Windows 98, and Windows NT.
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Introduction

Why use serial servers?
A serial server is an electronic device that provides Ethernet connections for 

signs and other serial devices by converting serial data to and from Ethernet 
format. 

A serial server is an economical way to add ALPHA signs to an existing LAN. 
Instead of running separate cabling to create a sign network, ALPHA signs can be 
attached to an existing Ethernet LAN using serial servers. This allows you to 
communicate with ALPHA signs across the room or around the world.

Why use ALPHA Ethernet Adapters?

TCP/IP compatibility

The ALPHA Ethernet Adapter supports a variety of TCP/IP features, 
including Telnet. The Telnet terminal protocol is an easy-to-use interface that 
creates terminal connections to any network host supporting Telnet.

Connectivity

The serial server connects devices directly to the Ethernet network, which 
conserves physical ports on the host, allows the terminal to access more than one 
host, and simplifies terminal cabling.

Standard cabling and connectors from Adaptive Micro Systems can be used 
with the ALPHA Ethernet Adapter.

Remote Configuration

The ALPHA Ethernet Adapter can be logged into and remotely configured 
via network login, Telnet login to the remote console port, or EZWebCon. 

Multi-protocol support and centralized management

ALPHA Ethernet Adapters from Adaptive Micro Systems and serial servers 
from Lantronix can be used on networks running TCP/IP, IPX/SPX, and LAT. 
They can be set up and managed over a network using EZWebCon and 
Redirector software from Lantronix.

Reloadable operating software

ALPHA Ethernet Adapters from Adaptive Micro Systems and serial servers 
from Lantronix are flash-ROM serial servers. Flash-ROM serial servers store their 
operating software permanently on-board, so they do not need to download code 
unless new versions become available. Serial servers can also be configured to 
request a downloaded configuration file at boot time.

Extensive technical support services

Technical information and telephone support, as well as the latest software, is 
readily available from your dealer, Adaptive Micro Systems, and Lantronix. (See 
“Set up locations in Smart Alec 2.1” on page 48 for details.)
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Types of serial servers available
Several serial servers are available for varying circumstances.

ALPHA Ethernet Adapter
• Allows you to connect an ALPHA sign to a 10BASE-T TCP/IP network.

• Needs no separate power supply. It gets its power directly from an ALPHA 
sign. Because of this, it is suitable for most, but not all, ALPHA signs. See 
Valid Adaptive signs for the ALPHA Ethernet Adapter below for a list.

MSS100
• Allows you to connect an ALPHA sign to a 100BASE-T or 10BASE-T TCP/IP 

network.

• Has its own power supply, therefore is suitable for all ALPHA signs.

• Allows a computer with only serial ports to communicate via a TCP/IP 
network, like a modem.

• Allows non-TCP/IP-aware software (such as AlphaNET plus for Windows) to 
communicate with ALPHA signs on TCP/IP networks.

MSS485
• Allows you to connect an RS485 network of up to 256 signs to a 10BASE-T 

TCP/IP network.

Valid Adaptive signs for the ALPHA Ethernet Adapter
The ALPHA Ethernet Adapter works with the following signs:

• BetaBrite (P1026)

• 215C, 215R

• 300C series

• 4000C, 4000R series (using RS232 jumper and jack)

• 7000C series (using RS232 jumper and jack)

• Personal Priority Display (PPD)

The ALPHA Ethernet Adapter may not work with the following signs, 
depending on your power source and electrical configuration:

• BetaBrite (P1036)

• 210C

• 220C

• AlphaVision

• Director
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Resources needed

Software

Software needed includes:

• Smart Alec, version 1.8 or 2.1, or

AlphaNET plus for Windows, version 1.2 

Additional software which may be needed includes:

• Lantronix Redirector, version B1.2/201 or better (if using AlphaNET 

plus for Windows)

• EZWebCon

• Telnet

Information on how to acquire and install additional necessary software is 
provided in this manual as needed. (Telnet is available with all Windows® 
operating systems.)

Hardware

Hardware needed includes:

• ALPHA Ethernet Adapter, and/or

MSS100 (for either Modem mode or Local/Remote mode) with power 
supply and cable to PC

• Functional sign with Smart Alec firmware chip, or

Functional sign with Alpha firmware chip 

• Power supply for each sign

• Active 10BASE-T Ethernet port

• Ethernet cable

• DB25-to-RJ11 adapter

• RS232 cable 

• PC connected to the Ethernet network 
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Description of the ALPHA Ethernet Adapter serial server

ALPHA Ethernet Adapter components

The primary components of the ALPHA Ethernet Adapter are shown here.

ALPHA Ethernet Adapter and connections

Below is a picture and description of the ALPHA Ethernet Adapter and its 
connections.

RJ45
Ethernet port

LED diagnostic lights:
1. ACT (activity)
2. LNK (network link/connection)
3. PWR (power)

Alpha Ethernet
Adapter

DB25
serial port

Ethernet cable

RJ11 cable

Alpha Ethernet
Adapter

DB25-to-RJ11
adapter

LED diagnostic lights
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Ways to send messages using serial servers from Adaptive
Without an ALPHA Ethernet Adapter serial server, the typical way to send a 

message is from a PC to a sign directly attached to the PC. ALPHA Ethernet 
Adapter serial servers add the flexibility of linking into an Ethernet LAN to send 
messages. There are several ways to use an ALPHA Ethernet Adapter in a LAN.

• In the Single server mode, an ALPHA Ethernet Adapter sends a message from 
one PC through a COM port (either physical or logical) over an Ethernet LAN 
to an ALPHA Ethernet Adapter and on to a sign.

• In the Modem mode, you can use an MSS100 serial server to emulate a modem 
sending messages one-at-a-time to one or more signs, each with an ALPHA 
Ethernet Adapter attached.

• In the Local/Remote mode, you can use an MSS100 as a “local/host” serial 
server to send messages all at once to one or more signs, each with a “remote” 
ALPHA Ethernet Adapter attached.

General steps to set up serial servers from Adaptive
1. First, install each serial server and assign each a unique network IP address.

2. Next, set up each serial server in the LAN in one of the modes listed above.

3. Finally, set up the messaging software – also in one of the modes listed 
above – to direct messages through the serial servers to a sign.
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Installing a serial server and setting its IP address

For messages to be sent to the correct signs on the network, each sign must 
have a unique IP address associated with it. There are several methods for 
assigning an IP address that can be used depending on various circumstances. For 
some of these methods, installation of the serial server hardware must be done 
while assigning the IP address. For other methods, the IP address can be assigned 
after the serial server hardware is installed.

To assign an IP address, you will need to know two numbers:

1. The valid IP address for each serial server, either MSS100 or ALPHA 
Ethernet Adapter. This is usually assigned by an IS network 
administrator.

2. The hardware address of the serial server. This is found on a label on the 
back of the server.

The following methods for assigning an IP address are listed in order from 
the most simple and most often used to the least often used.
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Method 1: EZWebCon
EZWebCon is one of the easiest ways to identify a serial server by its Ethernet 

address and assign a specific IP address.

NOTE: EZWebCon can not be used to set the IP address in Windows 3.1.

Install EZWebCon software

1. Obtain the latest version of EZWebCon (free) from the ALPHA Ethernet 
Adapter CD or from the Lantronix Internet site (ftp.lantronix.com/priv/
ezwebcon) for your network platform. Download this into an empty 
directory on the PC to be used.

2. After downloading, double-click on ezwebcon.exe in that folder on the PC.

3. The EZWebCon application will be unpacked and installed on your PC.

Detect existing ALPHA Ethernet Adapters on the network

1. Run EZWebCon software.

2. Click on the Micro-Serial Servers icon.
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3. Click on Browse in the MSS Management dialog box to search for existing 
ALPHA Ethernet Adapters on the network.

4. When browsing is complete, note all IP addresses returned in the Browse 

Network dialog box. Any IP addresses returned are existing ALPHA 
Ethernet Adapters hooked to the network. You will need this list for 
comparison later. (The only way to print this is to press the Print Screen 

button and then paste into a drawing, paint, or word processing 
application.)

Connect the ALPHA Ethernet Adapter to sign and network

5. Connect an Ethernet cable to an active port and to the RJ45 Ethernet port on 
the ALPHA Ethernet Adapter.

Ethernet cable
RJ11 cable

DB25-to-RJ11
adapter

Alpha Ethernet
Adapter

5

6

7

8

9
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6. Connect the ALPHA Ethernet Adapter to the DB25 connector.

7. Plug the RJ11 cable to the DB25 adapter.

8. Connect the other end of the RJ11 cable to a sign. 

9. Connect an appropriate power supply to the sign.

NOTE: The ALPHA Ethernet Adapter is now powered up and connected 
to the network. The LNK LED (middle LED) on the ALPHA 
Ethernet Adapter will be lit if you have a valid 10BASE-T network 
connection.

10. Check the LED lights on the ALPHA Ethernet Adapter:

The PWR LED should be solid green.

The LNK LED should be solid green with a valid network connection.

The ACT LED should be blinking green for normal operation. If it is 
blinking red, there is a problem.

NOTE: If your network uses DHCP and DHCP is enabled on the ALPHA 
Ethernet Adapter, then the network DHCP server will 
automatically detect the ALPHA Ethernet Adapter and assign an IP 
address to it. In this case, you should go to Step 19 in “Use 
EZWebCon software to detect newly-connected Alpha Ethernet 
Adapter and IP address” on page 13.

Use EZWebCon software to assign the IP address
NOTE: • If your network does not use DHCP or if DHCP is disabled on the 

ALPHA Ethernet Adapter, use this process (Step 11 through Step 
18). (The ALPHA Ethernet Adapter comes with DHCP disabled.)
• If your network uses DHCP and DHCP is enabled on the ALPHA 
Ethernet Adapter, then you should go to Step 19 in “Use 
EZWebCon software to detect newly-connected Alpha Ethernet 
Adapter and IP address” on page 13.

11. Click on the Lantronix logo button on the main screen for EZWebCon. This 
will display a pop-up menu.
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12. Choose Assign IP address to server.

13. Enter the Ethernet (hardware) address of the ALPHA Ethernet Adapter. 
This will always begin with “00-80-a3”.

HINT: This is case-sensitive and should be entered with lower-case letters, but you do not 
need to type the dashes.

14. Enter the new IP address.

HINT: To correctly position the nodes of the address, type both the numbers and the decimal 
points.

15. Leave Subnet address as “None”. Leave TFTP loadhost as zeroes or set as 
needed for your system. Leave Automatically connect and permanently assign 

the IP address checked.

16. Click OK.
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17. EZWebCon will check to see if the ALPHA Ethernet Adapter already has 
an assigned IP address. 

18. When EZWebCon has checked for an IP address:

• If it finds an IP address for this ALPHA Ethernet Adapter and it is the 
same as the one you are trying to assign, EZWebCon will simply tell 
you so. Click OK. 

• If it finds an IP address and it is not the same as the one you are trying 
to assign, EZWebCon will ask if you really want to assign the new 
address.

• Otherwise, it will assign the new IP address and will reboot the ALPHA 
Ethernet Adapter.
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Use EZWebCon software to detect newly-connected Alpha Ethernet
Adapter and IP address

NOTE: • If your network uses DHCP and DHCP is enabled on the ALPHA 
Ethernet Adapter, use this process (Step 19 through Step 22).
• If your network does not use DHCP or if DHCP is disabled on the 
ALPHA Ethernet Adapter, you should have used the process “Use 
EZWebCon software to assign the IP address” using Step 11 
through Step 18. (The ALPHA Ethernet Adapter comes with DHCP 
disabled. Call Adaptive Micro Systems’ Technical Services if you 
wish to enable DHCP.)

19. Click on the Refresh button in the Browse Network dialog box of EZWebCon. 
The purpose of this step is to search for the newly-connected ALPHA 

Ethernet Adapter on the network.

20. The IP address that the network DHCP server assigned to the ALPHA 
Ethernet Adapter should now be returned in the Browse Network dialog box 
in addition to any that were returned in Step 4. 

NOTE: If there are no new IP addresses returned, you must either program 
an IP address to the ALPHA Ethernet Adapter using Telnet, or 
contact IS personnel with the hardware address on the back of the 
ALPHA Ethernet Adapter. IS can then use network management 
software to locate the IP address that DHCP assigned.
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21. Note the IP address that the network DHCP server assigned to the ALPHA 
Ethernet Adapter, for use later.

NOTE: It may be a good idea to write the IP address directly on the 
ALPHA Ethernet Adapter.

22. Close EZWebCon.
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Method 2: Telnet
Telnet is used to program a hardware device for parameters such as baud 

rate, stop bits, parity, and particularly an IP address. Telnet can be used to assign 
an IP address directly. Telnet can also be used to “erase” an existing assigned IP 
address so that the arp command (see “Method 3: DOS/ARP command” on 
page 19) can assign a new IP address. 

Connect the ALPHA Ethernet Adapter to sign and network

1. Connect an Ethernet cable to an active port and to the RJ45 Ethernet port on 
the ALPHA Ethernet Adapter.

2. Connect the ALPHA Ethernet Adapter to the DB25 connector.

3. Plug the RJ11 cable to the DB25 adapter.

4. Connect the other end of the RJ11 cable to a sign. 

5. Connect an appropriate power supply to the sign.

NOTE: The ALPHA Ethernet Adapter is now powered up and connected 
to the network. The LNK LED (middle LED) on the ALPHA 
Ethernet Adapter will be lit if you have a valid 10BASE-T network 
connection.

NOTE: If your network uses DHCP and DHCP is enabled on the ALPHA 
Ethernet Adapter, then the network DHCP server will 
automatically detect the ALPHA Ethernet Adapter and assign an IP 
address to it.

6. Check the LED lights on the ALPHA Ethernet Adapter:

The PWR LED should be solid green.

The LNK LED should be solid green with a valid network connection.

The ACT LED should be blinking green for normal operation. If it is 
blinking red, this indicates there is a problem.

Ethernet cable
RJ11 cable

DB25-to-RJ11
adapter

Alpha Ethernet
Adapter

1

2

3

4

5
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Start Telnet

Telnet is fully functional on all PCs. To use Telnet, from Start > Run, type 
“Telnet”. It will open a generic window for Telnet. You can also open a Telnet 
window for a specific ALPHA Ethernet Adapter by typing “Telnet n.n.n.n” 
(where n.n.n.n is the assigned IP address of the ALPHA Ethernet Adapter) from 
Start > Run.

Assign an IP address

1. From the Connect menu, choose Remote System… and then select or type 
the IP address of the serial server. Use “telnet” for the Port and “vt100” for 
the TermType.

NOTE: Skip this step if you opened a Telnet window for a specific ALPHA 

Ethernet Adapter as above in “Start Telnet”.

2. Type a username and press Enter. It doesn’t matter what you type here, 
except that it must be different from that used by any other Telnet user on 
the network.



Installing a serial server and setting its IP address

Method 2: Telnet 17

3. The “show server” command can provide confirmation that you’ve 
accessed the correct ALPHA Ethernet Adapter and also provide statistics 
about that serial server.

4. Type “set priv”. Press Enter. Then type the password. Press Enter again.The 
default password is “system”.

5. You now have access to the “super user” level of authority. This is required 
to change the IP address. 

6a. To simply delete any currently-assigned IP address, type “change ipaddr 
0.0.0.0”
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6b. To assign a new IP address, whether or not there is a currently-assigned IP 
address, type “change ipaddr n.n.n.n” (where n.n.n.n is the new IP address.)

7. You should now reboot the ALPHA Ethernet Adapter. To do this, type “i d 
0” with spaces between the characters. (The last character is a zero.)

8. Because the ALPHA Ethernet Adapter will no longer be at the same 
address as when you connected to it using Telnet, Telnet officially logs you 
out of that connection.

9. You then get this notification. 

10. After clicking OK, and after the ALPHA Ethernet Adapter completes 
rebooting, you can connect to the server using the new IP address if you 
wish to confirm the change with the show server command. Alternatively, 
you can exit Telnet and send messages.
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Method 3: DOS/ARP command
In a DOS window in Windows 95 and Windows NT, the arp command is a 

simple way to assign an IP address when none has been previously assigned. The 
arp command is used here in conjunction with the ping command. The ping 
command is used to test the connection with the ALPHA Ethernet Adapter and to 
determine whether the new IP address has taken effect.

NOTE: The arp command will not work if any IP address has ever been 
assigned to the given hardware address. The arp command will not 
replace an existing IP address with another IP address. You can use 
Telnet to change or delete an existing IP address. Refer to “Method 
2: Telnet” on page 15.

Obtain new IP address(es)

1. Obtain a valid IP address for each ALPHA Ethernet Adapter. This is usually 
assigned by an IS network administrator.

Connect ALPHA Ethernet Adapter to sign and network

2. Connect an Ethernet cable to an active 10BASE-T Ethernet port and to the 
RJ45 Ethernet port on the ALPHA Ethernet Adapter.

3. Connect the DB25 adapter to the DB25 connector on the ALPHA Ethernet 
Adapter. 

4. Connect the RJ11 cable to the DB25 adapter. 

5. Connect the other end of the RJ11 cable to the sign.

NOTE: Do not connect the power cable to the sign at this time!

Set up DOS commands for assigning an IP address
6. Open up a DOS window on the PC: click on Start > Programs > MS-DOS 

Prompt.

Ethernet cable
RJ11 cable

Alpha Ethernet
Adapter

DB25-to-RJ11
adapter

2

3

4

5
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7. Type “ping –t n.n.n.n” (where n.n.n.n is the IP address to be assigned to the 
ALPHA Ethernet Adapter) and press Enter.

NOTE: This will continuously ping this IP address, allowing you to 
monitor exactly when communication to the device is established. 
You can stop the execution of this ping command by pressing 
Ctrl+c.

8. Open up another DOS window on the PC: click on Start > Programs > 

MS-DOS Prompt a second time.

9. Type “arp –s n.n.n.n 00-80-a3-x-x-x ” (where n.n.n.n is the IP address of the 
ALPHA Ethernet Adapter and 00-80-a3-x-x-x is the hardware address of 
ALPHA Ethernet Adapter.) Do not press Enter at this time though!

NOTE: You must first complete the next step to power up the unit before 
entering this command. The arp command typed here will be 
executed in Step 11 below. 
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Apply power to the ALPHA Ethernet Adapter and to the sign
10. Connect the appropriate power cable to the sign. Wait 30 seconds or until 

the ACT LED (top LED, closest to the DB25 serial port) turns off and on 
only every two seconds.

NOTE: Both the sign and the ALPHA Ethernet Adapter are now powered 
up and connected to the network. The LNK LED (middle LED) on 
the ALPHA Ethernet Adapter will be lit if you have a valid 
10BASE-T network connection.

Assign the IP address
11. Press Enter at the DOS window with the “arp –s n.n.n.n 00-80-a3-x-x-x” 

command, which you set up in Step 9 above, to actually assign the IP 
address.

NOTE: Once the ALPHA Ethernet Adapter is initially powered up, you 
have only two minutes to assign it an IP address by pressing Enter 
at the DOS window with the “arp –s n.n.n.n 00-80-a3-x-x-x” 
command which you set up in Step 9. After two minutes, either an 
alternate method must be used or the ALPHA Ethernet Adapter 
must be rebooted by removing and reapplying power to it.

12. You can watch the DOS window which has the ping command to 
determine when communication has been established. A “Reply from…” 
response will be displayed in the window with the ping command when 
successful IP assignment is achieved.
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13. Go to the DOS window which has the ping command. Stop the execution of 
this command by pressing Ctrl+c.

NOTE: The ALPHA Ethernet Adapter will not save the learned IP 

address permanently. The time it is saved may vary depending on 
how your network is set up. This arp and ping procedure is 
intended as a temporary measure to enable EZWebCon to 
communicate with the ALPHA Ethernet Adapter, or allow an 
administrator to Telnet into the ALPHA Ethernet Adapter. Once 
logged in, the administrator can enter the “Change IPaddress” 
command to make the address permanent. See also “Reserving an 
IP address” on page 23 for instructions on determining and 
reserving an IP address.
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Method 4: DHCP
Dynamic Host Control Protocol (DHCP) allows a device to use a dynamic IP 

address assigned at boot time from an available pool of addresses. 

The ALPHA Ethernet Adapter is shipped with DHCP disabled. However, if 
DHCP ever inadvertently becomes enabled, and if your LAN uses Dynamic Host 
Communications Protocol (DHCP), when the ALPHA Ethernet Adapter is re-
connected to the network and powered up, DHCP will automatically assign a 
dynamic IP address to the ALPHA Ethernet Adapter. If you want to accept this 
assigned IP address and don’t need to reassign another chosen address, you will 
still need see “Reserving an IP address” below for instructions on determining 
and reserving an IP address.

Reserving an IP address

Determine the IP address

So that you can send messages to the correct IP address, a system/network 
administrator must use the DHCP Manager (or similar) application to locate the 
ALPHA Ethernet Adapter by its hardware address. The dynamic IP address is 
associated with the hardware address. This identification process can be involved 
on large networks.

Reserving the IP address

A system/network administrator can use the system/networking DHCP 

Manager application to set the dynamically-assigned address to a permanent 
lease. This will reserve the IP address as a static address for the particular 
hardware address. If you do not reserve the IP address, periodically DHCP will 
automatically reassign a new dynamic – and typically different – IP address to the 
ALPHA Ethernet Adapter. The result is that messages will not be delivered to the 
ALPHA Ethernet Adapter.

Method 5: HyperTerminal
HyperTerminal may be used when, for some reason, you cannot access the 

serial server from the network. In this case, you will need to program the device 
directly using HyperTerminal and a null DB25F- or DB9F-to-DB25F serial cable 
(not supplied) from the PC to the server. (For an ALPHA Ethernet Adapter, 
however, you will need to split out two wires to connect the MSS device to an 
external power supply.) You will also need to use comm settings of 9600 baud, 
8N1, and flow control set to either XON/XOFF or HARDWARE. For assistance, 
please call Technical Support at Adaptive Micro Systems.

NOTE: HyperTerminal is fully functional on all PCs, but you may need to 
install it with the Add/Remove Programs icon in the Control Panel.
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Single server mode

In the Single server mode, an ALPHA Ethernet Adapter sends a message from 
one PC through a COM port (either physical or logical) over an Ethernet LAN to 
an ALPHA Ethernet Adapter and on to a sign.

Lantronix Redirector software is used to redirect messages normally sent 
through a PC COM port to a sign. Redirector associates the PC COM port with a 
network IP address for an ALPHA Ethernet Adapter. The ALPHA Ethernet 
Adapter, in turn, is connected to the sign and sends the message on to the sign. In 
other words, Redirector intercepts messages going to the COM port and sends 
them over the network to the ALPHA Ethernet Adapter’s serial port and to the 
sign. 

This mode is especially used in conjunction with AlphaNET plus for 

Windows software.

NOTE: The COM port you choose to use can not be in use by any other 
device, for example, an internal modem. To determine which ports 
are in use, from Start > Settings > Control Panel, choose System and 
go to the Device Manager tab. In the Ports directory, determine the 
COM ports currently in use. The Redirector application allows up 
to 40 logical COM ports to be redirected. You can redirect any 
except those currently in use. However, AlphaNET plus for 

Windows only recognizes COM ports 1 through 4.

Install Redirector
1. Obtain the latest version of Redirector from the ALPHA Ethernet Adapter 

CD or from the Lantronix Internet site (ftp.lantronix.com/priv/redirector) 
for your network platform. Download this into an empty folder on the PC 
to be used.

2. After downloaded, double-click on redirector.exe in that folder on the PC.

3. The Redirector application will be unpacked and installed on your PC.

ALPHA Ethernet Adapter

Ethernet LAN (10BASE-T) using TCP/IP protocol

AlphaNET plus for Windows 
software

ALPHA Ethernet Adapter
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Direct a COM port to a serial server (hardware)
1. Run the Lantronix Redirector software. In the RDCfg Dialog box, click the 

Port Setup icon.

2. Choose an available COM port that you wish to redirect to the ALPHA 
Ethernet Adapter IP address. Click OK.

NOTE: If you need to use the same COM port for other purposes, you will 
need to de-select the COM port in the same way as the above two 
step. Then quit all applications and reboot the computer.
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3. Click the ADD IP button. In the IP Service Setup dialog box, enter the IP 
address of the ALPHA Ethernet Adapter that EZWebCon detected in the 
Host prompt. In the TCPPort prompt, enter “3001”, the valid number for 
any ALPHA Ethernet Adapter. Click OK.

4. Click Save in the RDCfg dialog box.

5. Click OK in the Config Info box.
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6. Click Close in RDCfg dialog box. 

7. You may need to reboot the computer. You should now be able to access the 
sign via AlphaNET plus for Windows and/or Smart Alec via the network.

Direct a COM port to a serial server (software)

AlphaNET plus for Windows
Setting the device and COM port

For AlphaNET plus for Windows, in the Site Editor, you must choose the 
COM port that you chose to be redirected to the IP address of the ALPHA 
Ethernet Adapter.

1. Run the Site Manager. Choose Edit > Device… Click the New button.

2. Provide a name for this ALPHA Ethernet Adapter and click OK.

Instead of creating a new device, you can 
select a wired device that is pre-installed, 
such as “Local wired on COM1”. If you do 
so, skip to Step 4.

HINT: You can show all the pre-installed 
devices by clicking the Install button. You 
must then select one to make it available.
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3. Choose the correct COM port for your computer. Set the Data Format at 8N1 
(8 bits, no parity, 1 stop bit.) Set the Baud Rate at 9600. Click OK.

4. If this ALPHA Ethernet Adapter will be the primary transmission device, 
click on the Make Default button. If this ALPHA Ethernet Adapter is the only 
transmission device, you must make it the default. 

5. By confirming this selection, this ALPHA Ethernet Adapter will be 
designated the default device. Click Yes and then Close.
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6. Choose the desired site (or create a new one.) Then choose Open Site from 
the File menu.

7. Choose the Connect Device that you just set up in the previous steps.
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8. Click on the Site Info tab. Set the Address List to the serial address(es) of the 
sign(s). Click OK. By doing this, you can send messages to individual 
sign(s) in the address list.

Sending messages from AlphaNET plus for Windows

You are now ready to send messages to this sign using AlphaNET plus for 

Windows. 

1. Send your message(s) as you normally would.

2. The Redirector will alert you that it is connecting to the ALPHA Ethernet 
Adapter serial server. 

3. You will briefly receive this notice.

4. And this is the last notice. Normally you will not see these notices for more 
than a very brief time. 

5. Any messages will be sent to the sign.



Single server mode

Direct a COM port to a serial server (software) 31

Smart Alec 1.8

When using Single server mode and Smart Alec version 1.8, you can access 
the sign as a LAN device location.

1. Create a new LAN location. 

2. Assign a Name, Address List, and IP Address to this device for the ALPHA 
Ethernet Adapter. Then click on the Advanced button.

3. Click on the Properties button.

4. Type “3001” for the Service Port.

5. Choose OK until the Location is defined.

6. You are now ready to send messages to this ALPHA Ethernet Adapter site 
as you normally would in Smart Alec 1.8.

For the Address List, the address entered must 
match the address of the sign (e.g., address 00.)

For the IP address, enter the IP address 
assigned to the ALPHA Ethernet Adapter.
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Smart Alec 2.1

When using Single server mode and Smart Alec version 2.1, you can access 
the sign as a terminal server.

1. In Notification Device Interface Setup, choose File > New > Terminal Server.

2. Assign a Name, Description, and IP Address. Click Add. 

3. In Notification Device Setup, choose File > New > Alpha SA device.

4. Complete the choices for this notification device. Choose “Terminal Server” 
for Interface Category and then your specific Interface Name as in Step 2 
above. The Interface Port Address must be “3001”. Click Add. 

5. You are now ready to send messages to this ALPHA Ethernet Adapter 
destination as you normally would in Smart Alec 2.1.

For the IP address, enter the 
IP address assigned to the 
ALPHA Ethernet Adapter.

The Interface Port Address 
must be “3001”.
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Modem mode

In the Modem mode, you can use an MSS100 serial server to emulate a modem 
sending messages one-at-a-time to one or more signs, each with an ALPHA 
Ethernet Adapter attached.

Set up the MSS100 as a sending modem
NOTE 1: You must have programmed the MSS100 serial server with an IP 

address before setting it up in modem mode.

NOTE 2: The version of the firmware of the MSS100 serial server must be 
version B3.5/905 (dated 990518) or higher.

1. Choose Start > Run. Type “Telnet n.n.n.n” where n.n.n.n is the assigned IP 
address for the MSS100. Click OK.

ALPHA Ethernet Adapter

Ethernet LAN (10BASE-T) using TCP/IP protocol

AlphaNET plus for Windows 
software

ALPHA Ethernet Adapter

MSS100

DB25F- or DB9F-to-DB25F
null modem cable
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2. Type a username and press Enter. It doesn’t matter what you type here, 
except that it must be different from that used by any other Telnet user on 
the network.

3. Type “set priv”. Press Enter. Then type the password. Press Enter again.The 
default password is “system”.

4. Type “change flow control none”. Press Enter. 

5. Type “change modem emulation enabled”. Press Enter. 
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6. Type “show port”. Press Enter. This will show the current settings of the 
port. The settings will look something like this: 

7. Repeat Step 1 through Step 6 above for all of the MSS100 serial servers to be 
used in modem mode.

8. Remove power from these servers and re-apply power, after which changes 
will be in effect. You must now proceed to “Set up sites in AlphaNET plus 
for Windows”, described next.

Set up sites in AlphaNET plus for Windows
In AlphaNET plus for Windows, in the Site Editor, you must define a device 

that uses the correct settings for the MSS100 to emulate a sending modem. You 
must also create a separate site for each of the ALPHA Ethernet Adapters that 
uses the new device for receiving messages.

1. Run the Site Manager. Choose Device… from the Edit menu. Click the New 
button.
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2. Provide a name for this MSS100 device and click OK.

3. In this window, choose the appropriate settings for the MSS100. Click OK.

4. If this MSS100 will be the primary transmission device, click on the Make 

Default button. If this MSS100 is the only transmission device, you must 
make it the default. 

5. By confirming this selection, this MSS100 will be designated the default 
device. Click Yes and then Close.

COM port must be the one that the MSS100 is using.

Data Format must be 8N1 (8 bits, no parity, 1 stop bit)

Baud Rate must be 9600

Modem checkbox must be checked
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6. Choose New Site from the File menu.

7. Specify a site name. Choose the Connect Device that you just set up in the 
previous steps. Type the Phone Number as “n.n.n.n:3001T” where n.n.n.n is 
the assigned IP address of the receiving ALPHA Ethernet Adapter. Click 
OK. 

8. You are now ready to send messages to this ALPHA Ethernet Adapter site 
as you normally would in AlphaNET plus for Windows.

NOTE
You must create a new 
site for each unique 
serial address on signs.
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Local/Remote mode

In the Local/Remote mode, you can use an MSS100 as a “local/host” serial 
server to send messages all at once to one or more signs, each with a “remote” 
ALPHA Ethernet Adapter attached.

In this mode, you set one MSS100 as the local/host device. When setting up 
the MSS100, you assign it a fixed list of up to 12 IP addresses of ALPHA Ethernet 
Adapters. You set up each ALPHA Ethernet Adapter as a remote device. Then 
you can use the local/host device to send messages at one time to all the remote 
devices in the fixed list. You can also send messages to individual signs by using 
unique addresses for signs with the ALPHA Ethernet Adapters.

Set up the MSS100 to act as a local device
NOTE 1: You must program the MSS100 devices with IP addresses before 

setting them up.

NOTE 2: The version of the firmware of the MSS100 must be version 
B3.5/905 (dated 990518) or higher.

ALPHA Ethernet Adapter

Ethernet LAN (10BASE-T) using TCP/IP protocol

AlphaNET plus for Windows 
software

ALPHA Ethernet Adapter

MSS100

DB25F- or DB9F-to-DB25F
null modem cable
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1. Choose Start > Run. Type “Telnet n.n.n.n” where n.n.n.n is the assigned IP 
address for the MSS100. Click OK.

2. Type a user name and press Enter. It doesn’t matter what you type here, 
except that it must be different from that used by any other Telnet user on 
the network.

3. Type “set priv”. Press Enter. Then type the password. Press Enter again.The 
default password is “system”.

4. Type “change flow control none”. Press Enter. 

5. Type “change access local”. Press Enter. 
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6. Type “change dedicated hostlist”. Press Enter. 

7. Type “host add tcp n.n.n.n:3001T” where n.n.n.n is the IP address of an 
ALPHA Ethernet Adapter to be used in remote mode. Press Enter. Do this 

step for each remote ALPHA Ethernet Adapter which is to receive messages from 

the local MSS100. 

8. Type “change autostart enable”. Press Enter. 

NOTE
There is a maximum of twelve 
(12) remote ALPHA Ethernet 
Adapters, and therefore, twelve 
signs, that can receive messages 
from a local MSS100.
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9. Type “show hostlist”. Press Enter. This will show the list of the remote 
ALPHA Ethernet Adapter IP addresses you entered. 

10. Type “show port”. Press Enter. This will show the current settings of the 
port. 

Set up ALPHA Ethernet Adapters to act as remote devices
NOTE 1: You must have programmed all the ALPHA Ethernet Adapters 

with IP addresses before setting them up in remote mode.

NOTE 2: The version of the firmware of the ALPHA Ethernet Adapters 
must be version B3.5/905 (dated 990518) or higher. 
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1. Choose Start > Run. Type “Telnet n.n.n.n” where n.n.n.n is the assigned IP 
address for a remote ALPHA Ethernet Adapter. Click OK.

2. Type a username and press Enter. It doesn’t matter what you type here, 
except that it must be different from that used by any other Telnet user on 
the network.

3. Type “set priv”. Press Enter. Then type the password. Press Enter again.The 
default password is “system”.

4. Type “change flow control none”. Press Enter. 
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5. Type “change access remote”. Press Enter. 

6. Type “show port”. Press Enter. show the current settings of the port. 

7. Repeat Step 1 through Step 7 above for all of the ALPHA Ethernet Adapters 
to be used in remote mode.

Reset and check all devices
1. Remove power from all the remote ALPHA Ethernet Adapters and re-

apply power.

2. Next, remove power from all the local MSS100 devices and re-apply power.

3. Choose Start > Run. Type “Telnet n.n.n.n” where n.n.n.n is the assigned IP 
address for the local MSS100 devices. Click OK.

4. Enter a username and password.
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5. Type “show port”. Press Enter. This will show the current settings of the 
port. In the settings, there is a Sessions entry. This number is the number of 
remote ALPHA Ethernet Adapters you set up for the local MSS100 to send 
messages to. 

Set up sites in AlphaNET plus for Windows
In AlphaNET plus for Windows, in the Site Editor, you must define a device 

that uses the correct settings for the MSS100 to send messages. You must also 
create a site for the MSS100, using the new device.

1. Run the Site Manager. Choose Device… from the Edit menu. Click the New 
button.

2. Provide a name for this MSS100 device and click OK.
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3. In this window, choose the appropriate settings for the MSS100. Click OK.

4. If this MSS100 will be the primary transmission device, click on the Make 

Default button. If this MSS100 is the only transmission device, you must 
make it the default. 

5. By confirming this selection, this MSS100 will be designated the default 
device. Click Yes and then Close.

COM port must be the one that the MSS100 is using.

Data Format must be 8N1 (8 bits, no parity, 1 stop bit).

Baud Rate must be 9600.
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6. Choose New Site from the File menu.

7. Specify a Site Name. Choose the Connect Device that you set up for the 
correct MSS100 to receive messages.

8. If you want to send messages to any specific signs, set the Address List for 
this site to the specific sign serial address(es).

9. You are now ready to send messages as you normally would. Messages will 
go to the MSS100, which, in turn, will send the messages on to all the 
ALPHA Ethernet Adapters that it is set to send to, as shown in Step 9 on 
page 41. Any message will be shown only on the ALPHA Ethernet 
Adapter/sign with the serial address that matches the site the message is 
sent to.

NOTE
You must create a new 
site for each unique 
serial address on signs.
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Set up locations in Smart Alec 1.8
When using Local/Remote mode and Smart Alec version 1.8, you can access 

the sign as a Wired device location.

1. Create a new Alpha SA Wired location.

2. Assign a Name and set the Address List to the serial address of the sign. 
Choose the Advanced button on this screen and the Properties button on the 
next.

3. Choose the correct properties for this Location. Click OK for this and the 
next two screens, until the Location is defined. 

4. The Smart Alec administrator must then authorize the user for the new 
location.

5. Messages can now be sent from Smart Alec to the sign. The messages will 
go to all locations that the local MSS100 is set to send to. Any message will 
be shown only on the sign with the serial address that matches the site the 
message is sent to.

NOTE
You must create a new 
location for each unique 
serial address on signs.

For the Address List, the 
address entered must 
match the address of the 
sign (e.g., address 1.)

Parity must be “none”.

Baud Rate must be “9600”.
The Connector must be set to the COM port you 
chose to be redirected to the IP address of the 
ALPHA Ethernet Adapter.

Data Bits must be “8”.
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Set up locations in Smart Alec 2.1
When using Local/Remote mode and Smart Alec version 2.1, you can access 

the sign as a Serial device location.

1. In Notification Device Interface Setup, choose File > New > Serial interface.

2. Complete the choices for this notification device interface. Click Add. 

3. In Notification Device Setup, choose File > New > Alpha SA device.

4. Choose the correct properties for this notification device. Choose “Serial” 
for Interface Category and then your specific Interface Name as in Step 2 
above. Click Add. 

5. You are now ready to send messages to this ALPHA Ethernet Adapter site 
as you normally would in Smart Alec 2.1. The messages will go to all 
destinations that the local MSS100 is set to send to. Any message will be 
shown only on the sign with the serial address that matches the 
destinations the message is sent to.

The COM Port must be set to the COM 
port you chose to be redirected to the IP 
address of the ALPHA Ethernet Adapter.

Parity must be “none”.

Baud Rate must be “9600”.

Data Bits must be “8”.

Stop Bits must be “1”.
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Technical support

Support services

Technical information

Software is available at Adaptive’s Internet World Wide Web site

http://www.ams-i.com.

Technical information, as well as the latest Ethernet networking software, is 
available from the Lantronix Internet site:

http://www.lantronix.com

Technical support

For additional support, please contact your local dealer, or call the Technical 
Support department at Adaptive Micro Systems, Inc. at 1-800-558-7022 between 
the hours of 8:00 AM and 5:00 PM Central Standard Time.
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